Page 1 of 1

Sim Won't Sleep, Possibly "Stuck" Between Ages?

PostPosted: September 7th, 2014, 3:50 pm
by ambaharmony
Backstory: I tried using the birthday cake a day or two before my sim's birthday, she would be aging into a teen. After clicking "Blow Out Candles" and doing the whole birthday animation thing, she didn't age up. This happens pretty often, and to fix it I enable the testingcheats and use the "Trigger Age Transition" when shift-clicking on the sim. This always works. However, when I did it with this sim, she still didn't age up. I decided to just continue playing until the game forced her to age.

Shortly after this, however, I realized that she will not sleep. She can nap and relax on beds, but not sleep. When I click on the sleep interaction, the icon appears in the top left corner for a moment then disappears. I got a notification that it was her birthday, but she didn't seem to be forced to aged up by the game by the end of that day.

I've tried restarting the game, the resetsim cheat, and buying new beds. I even tried killing and resurrecting her but that didn't fix it either. I haven't installed any new custom content in a long time and I've aged up plenty of sims since then so I'm almost positive that's not the problem. I've tried moving the family out and back in or to a different neighborhood, but the game always freezes at some point of the moving process (it doesn't with other families). I also noticed that using the "Edit in CAS" cheat on her results in freezing, where it works perfectly fine for other sims. My theory as to what's wrong is that when I tried to age her up using cheats too quickly after trying with the cake I somehow got her "stuck" between being a child and teen. I'm starting to think this sim is corrupted beyond repair. Anyone ever experience anything similar or have ideas on how to fix?

Re: Sim Won't Sleep, Possibly "Stuck" Between Ages?

PostPosted: September 11th, 2014, 8:39 pm
by somebodysangel
I've had this issue, and tried everything you tried.

Do you use mods? The way I fixed mine was to allow nraas ErrorTrap to reset her, then age her up in CAS. There was some kind of script error, I believe.